Forms Unable to be Created
Incident Report for Rhumbix
Resolved
There was an issue with data backing Form statuses and has been resolved. No customer data was effected during the incident.
Posted Nov 04, 2022 - 09:44 PDT
Monitoring
We have implemented a fix and are continuing to monitor the application.
Posted Nov 04, 2022 - 09:27 PDT
Identified
An issue has been identified that is preventing Forms from being created. We are actively working on a fix.
Posted Nov 04, 2022 - 08:41 PDT
This incident affected: Rhumbix.