Mobile login issues

Incident Report for Rhumbix

Resolved

This incident has been resolved.
Posted Jul 15, 2026 - 10:25 PDT

Monitoring

We have implemented a fix at the network level, users may experience temporary connection issues until DNS flushes.
Posted Jul 15, 2026 - 08:42 PDT

Identified

We have identified the issue and are working on a solution
Posted Jul 15, 2026 - 07:56 PDT

Investigating

There is an issue impacting login from mobile on the latest version of the app. We are investigating.
Posted Jul 15, 2026 - 07:15 PDT
This incident affected: Rhumbix.