Email and PDF slowdown
Incident Report for Rhumbix
Resolved
This incident has been resolved.
Posted Oct 04, 2022 - 13:21 PDT
Investigating
For the next 90 minutes or so users may experience delays in receiving emails and having their PDFs generated.
Posted Oct 04, 2022 - 11:21 PDT
This incident affected: Rhumbix.